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Mixcraft How-To
Basics

Getting help

There are lost of good quality tutorial videos that teach you the basics of Mixcraft - many by Acoustica 
(the company that makes Mixcraft) themselves.  You should also take a look at the Help Topics in the 
Help menu of Mixcraft. 

Videos

• Mixcraft tutorials on Mixcraft website (and Youtube) http://www.acoustica.com/mixcraft/v6/help/
video-tutorials.htm 

• Mixcraft 6 Tutorial The Basics (created by a Mixcraft user): http://www.youtube.com/watch?
v=Tkst8MlP6BI 

• There are many others.  Go to Youtube and search “Mixcraft tutorial” or “how-to”

Teacher’s Guide

Acous&ca	  have	  published	  an	  excellent	  free	  Teacher’s	  Guide	  which	  is	  available	  for	  download	  from	  their	  
website.	  	  It	  includes	  lots	  of	  step-‐by-‐step	  projects,	  how-‐to	  instruc&ons	  and	  sample	  files	  for	  you	  to	  use	  with	  
your	  students.

Starting a new project

Open	  MixcraD	  and	  in	  the	  New	  Project	  window,	  give	  your	  project	  a	  name	  and	  choose	  your	  project	  type.	  	  
Most	  are	  self-‐explanatory	  and	  its	  not	  the	  end	  of	  the	  world	  if	  you	  choose	  the	  wrong	  one!
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Mixcraft screen

Zooming

To	  zoom	  the	  project	  area	  in	  and	  out,	  you	  can	  hover	  your	  mouse	  in	  the	  Timeline	  area	  and	  use	  the	  mouse	  
wheel	  to	  zoom	  in	  and	  out.	  	  	  You	  can	  also	  zoom	  by	  using	  the	  +	  and	  -‐	  buJons.

Using loops

Searching for loops

• To see the Mixcraft loop library, click on the Library tab
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• You can use the Library and Sort By drop-down menus to narrow your choices: select loops by 
style, genre or instrument

• You can also type something into the search box - such as “drums” or “dubstep”

• Click on the green Play button next to the loop to hear it play back

Adding a loop to your project

When you’ve found a loop you like you can add it to your project by doing one of the following:

• Drag it up into the project area

• Select an audio track, place the playback line where you want the loop to go and click on the plus 
button next to the loop name.  Mixcraft will add the loop into the timeline area

Each loop or snippet of music that appears in your Mixcraft project is known as a Region or Clip.

Reset the loop browser

If	  you	  used	  the	  search	  field	  to	  look	  for	  a	  loop,	  you	  will	  need	  to	  clear	  the	  search	  box	  by	  clicking	  on	  the	  cross	  
(to	  delete	  your	  search	  text).

Playback

You	  can	  play	  back	  the	  project	  in	  a	  number	  of	  ways:

• Click	  on	  the	  Play	  buJon	  on	  the	  Transport	  controls	  (right)

• Use	  the	  Space	  bar	  to	  start	  and	  stop	  playback

• Use	  the	  Home	  and	  End	  keys	  to	  jump	  to	  start	  or	  finish

• Use	  Ctrl+.	  (full	  stop	  key)	  to	  fast	  forward	  or	  Ctrl+,	  (comma)	  to	  rewind

Adding sound effects to a project

A word about snapping

Snapping is a feature that causes loops or recorded audio to “snap” to the 

beginning of a bar, or to a speci"c beat.  This is highly useful when you’re doing 
a music project since you’ll nearly always want the music to adhere to bars and 
beats in a song.

However, if you are working on podcasting,  storytelling, or adding sounds 
effects to a "lm scoring project, it’s unlikely that you’ll want snapping enabled 
since dialogue and sound effects don’t conform to bars and beats.

You can turn snapping off by going to clicking on the Snapping drop-down 
menu on the Toolbar.  Select Snap Off (see right). 
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Adding sound effects

Once you’ve turned off the snapping function, you can add a sound effect to your project in the same 
way you would add a music loop - by dragging it into the timeline area, or by positioning the playback 
line and then using the plus button next to the loop name to add it to the project.

Once the sound effect is in the timeline area, you can drag it left or right with your mouse to position it 
more precisely.

Adding a virtual instrument 

Add a new virtual instrument track

A virtual instrument track allows you to record music into your project by using the on-screen keyboard, 
or by playing an external MIDI keyboard that you have plugged into your computer.

• Go to Track > Add track and choose Virtual Instrument Track (or use the shortcut Ctrl+E)

• A new Instrument track will be created with the default grand piano sound

Change instrument sound

To change the instrument sound:  

• First, click on the Change Instrument button on the track header

• Select an instrument Category on the left-hand side of the panel

• Then select a speci"c Instrument Preset within that family on the right-hand side of the panel 
(below)

• Click on the Musical Typing button to open the #oating on-screen keyboard.  This allows you to 
play notes by using the keys on your computer keyboard (or by clicking on the screen)

• Press the letters A – L on your computer keyboard to audition the instrument sound
8



Recording a virtual instrument

Prepare to record 

• Before you record, make sure the Musical Typing window is open, or that you have access to a MIDI 
keyboard

• If you’re going to play something musical (in time to a 
beat), click on the Metronome icon next to the Transport 
controls and turn on the Recording and Recording Count-
In Measures options on.  If you’re going to play something 
non-musical (like sound effects) then turn those options off

Record some music

• Make sure the instrument track is selected

• Rewind the playback line to beginning (or move it to the place you want to start recording from)

• Press the Record button, wait for the count-in bar (if applicable) and then record the part

Recording a drum pattern

The steps for recording a drum part are essentially the same as the Recording a Software Instrument 
instructions, but there are a couple of other things you should do:

Prepare to record 

• Before you record, make sure the Musical Typing window is open, or that you have access to a MIDI 
keyboard

• Locate the kick, snare and hi-hat sounds!  Make sure your Musical Typing keyboard is using the C1 
octave.  The kick can then be triggered with the A key on your computer keyboard, the snare with 
the S key and the closed hi-hat with the T key

• Make sure the Metronome and Count-in are turned on: click on the Metronome icon to check these 
settings

• Adjust the tempo if necessary. You do not need to record the drum pattern at speed - slow it down 
to 80 BPM if you like and then speed it up again when you’ve "nished

Set up the loop region

When recording drum patterns, it’s a good idea to record just one or two bars.  You can then drag the end 
of your recorded region to make the pattern longer.  To record the pattern, we’ll set up a one or two-bar 
cycle which Mixcraft will play over and over.  On each “pass” of the cycle you can record a different part of 
the drum pattern.
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• Click on the Loop Mode button located to the right of the Transport control 
(see right).  A loop region with show in the timeline area (the non-loop 
region will be greyed-out)

• Adjust the length of the loop region by dragging the Loop End in the Timeline.  I usually suggest 
making the loop region two bars long

Record the pattern

• Arm the drum track for recording

• Rewind the playback line to beginning of the loop region

• Don’t forget that if you do not feel con"dent about playing the drum pattern at the project tempo, 
slow the tempo down "rst, before hitting the record button!

• Press the Record button, wait for the count-in bar and then record the kick drum part only

• When the playback line returns to the beginning of the cycle region, play the snare part

• When it returns to the beginning again, play the hi-hat part

It doesn’t matter if you don’t start playing each part straight away, one after the other, just wait for the 
beginning of the  loop region and then play.  You can even stop or pause the recording and then start 
recording again.

When you’ve "nished, disarm the track.

Combine parts

Each of the parts will end up on its own “lane” on the track (see below).

To combine the 3 parts into one:

• Control-click on all 3 clips (or double-click the track header to select everything on the track - 
useful if this is the only thing on the track so far)
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• Right-click on any one of the parts and choose merge.  The 3 parts will merge into the "rst one

• To delete the empty lanes, right-
click on the track header and 
choose Lanes > Delete empty 
lanes

Quantize

You can quantize the drum pattern to even-up any uneven playing:

• Double-click on the drum pattern region to open the piano roll editor at the bottom of the screen

• Click on MIDI Editing > Quantize and then select an appropriate value from the Note Type drop-
down menu (usually 8th or 16th notes)

Recording a speaking or singing track
To record a speaking or singing track:

• Select an audio track.  If there is no empty audio track in your project, you can add a new one by 
going to Track > Add Track > Audio Track

• On the track header, select your 
recording input device (microphone) 
from the drop-down menu (see right)
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• Test the levels by speaking or singing into the 
microphone - you should see the meter moving.  
You want to make sure the meter is showing 
green/yellow levels and not red (which means 
the recording will be distorted).  If you are seeing red, move away from the microphone, or adjust 
the recording level by using the slider on the track header (tip: the slider allows you adjust the 
recording level when you have armed the track for recording.  When the track is disarmed, it 
becomes the volume slide for that track)

• Check that the track is armed for recording (the track header should be red)

• Put some headphones on your singer so that they can hear the backing track (if applicable) and so 
that the sound of any previously-recorded tracks does not come out of the computer speakers

• If your singer would like to hear their own voice, 
as well as the other tracks, click on the Monitor 
Incoming Audio button on the track header (see 
right)

Adding Effects

Using voice effects can give students a boost in con"dence - they’re more comfortable recording their 
voice when it sounds different, or is disguised a little!

You can choose to add effects - such as AM Radio, Megaphone, Chipmunk, or reverb - to a voice track (or 
other audio track) while you’re recording, or after you’ve "nished recording.

To add an effect to the track:

• Click on the FX button on the track header

• In the window that opens, select one of the Vocal effect options in the Effect Chains drop-down 
menu (see below)

You can also build your own effects from scratch or adjust the preset effects by using the options in the 
lower part of the Effects window.
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Delete a track

To delete a track:

• Select the track

• Go to Track > Delete Track, use the shortcut Ctrl+Shift+D or right-click on the track header and 
select Delete Track

Editing Regions

Increase or decrease the length of a loop

• You can lengthen a loop by hovering your mouse at the top right 
corner until you see a double-headed arrow (see right)

• Click and drag your mouse to the right to increase the length of the 
loop.  Drag to the left to decrease the length of the loop

Increase the length of a loop (option #2)

• You can use the +1 Loop button on the region itself to add 
another instance of that loop at the end (see right)

Copy and paste loops

• Select a region

• Press Ctrl+C to copy it

• Place the playback line at the destination point

• Paste by pressing Ctrl+V

Split

• Select the region you want to split

• Place the playback line (cursor) at the point you want to split the region

• Go to Edit > Split or use the shortcut Ctrl+T

The Edit window

To edit regions in more detail, you can use the Sound tab.

• Double-click on the region you wish to edit (or select the track and click on the Sound tab)

• The selected region will appear in detail at the bottom of the screen
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Editing MIDI

Edit notes

To edit a MIDI region (correct mistakes, or add new notes):

• Double-click on the region you wish to edit (or select the track and click on the Sound tab)

• The selected region will appear in detail in the MIDI editing window at the bottom of the screen 

• If you can’t see the MIDI notes, you may need	  to	  scroll	  up	  or	  down	  within	  the	  MIDI	  edi&ng	  window

Select a note and then:

• Drag it up or down to change the pitch

• Drag it left or right to change the rhythmic position

• Shorten or lengthen the note by dragging the end

Selecting groups of notes

You can select more than one note by doing one of the following:

• Ctrl-click or Shift-click on each one

• Click and drag a “lasso” around a group of notes that are 
near one another (see right)

Transposing groups of notes

Once a group of notes has been selected, they can be transposed 
all at the same time:

• Select	  the	  notes

• Drag one of the notes up or down (all the other  notes will move up simultaneously)

Fade-ins, fade-outs and panning (track & project automation)

Varying the volume of the overall project

• Go to Track > Show Master Track
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• You can click on the volume line to add “points”.  Drag the points up or down to vary the volume 
(see below)

Varying the volume on a single track

• You can fade sound effects and music in or out by adding a “volume envelope” to that track

• Click on the Toggle Automation button on the track header.  The track volume info will appear 
underneath the selected track  

• Click on the volume line to create points and drag the points up or down to adjust the volume level 
(see below)

Track pan

You can adjust the track pan (the level of sound in each speaker or headphone) in the same way.  Track 
pan is useful when you want to create an effect of footsteps or a car moving from one speaker to the 
other.

• From the automation drop-down menu, select Track Pan (see 
right)

• Add points to the line and then drag them up or down to vary the 
track pan

Adding loops in to the loop library

Creating loops from sounds in your project

Any sounds that are a part of your project can be added to the loop library.
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• Right-click on the sound in your project

• Select Add To Library

• In the dialog that opens (see right), select the 
library you would like to import to (type in a new 
name if you want to start a new library)

• Select the Song Kit you would like the sound to be 
associated with

• Choose whether you’d like track effects and clip envelopes to be applied when importing

• Click Add

Importing loops from your hard drive

You can import individual loops, or folders of loops from your computer’s hard drive into the Mixcraft 
library.

• Click on the Library tab

• Click the +Import button (see below)

• The Import To Library window will open with various options.  To locate the loops on your hard 
drive, click on the Browse button

• Choose your other settings and click Import

You can also open Windows Explorer and drag a folder of loops into the Library window. 

For more information about each of the options in this window, see Mixcraft 6 Help.

Editing the content of the Library
You can edit loop information such as the loop name, the tempo, key signature time signature, style and 
so on.

• Click on the Library tab

• Click on Edit Library (see right)

• Sounds or loops that you can edit will have a pencil icon 
next to them.  Click on the "eld that you want to edit and 
type the new information

• When you’ve "nished, click the Stop Editing button
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Beat-matching stems

1. Setting up a new project

• Start a new project choose the Build Loop and Beat Matched Music template

• On the Project tab make sure Auto Beat Match is on

• Drag the audio "le from Windows Explorer or from the Library tab in Mixcraft on to the main 
project area

• A dialog box will probably appear: Use Best Sounding 
Project Tempo? Say yes and take note of tempo 
identi"ed

• Drag the audio region to bar 1 beat 1

• Set the Metronome to play during playback (see right) and 
press Play.  Does the audio "le match the metronome tempo?  
Is it in sync for the entire song?  If yes, good!

2. Work out project tempo and key

If the audio "le is not in sync and does not start on a downbeat (most likely), follow these steps:

• Figure out the real tempo of the audio "le.  You can use an online metronome, or an iPhone/iPad 
app which will identify a tempo that you tap

• If it’s a melodic part, work out the key as well

•  On the Project tab, "ll in the correct tempo and key settings
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3. Adjust individual audio "le tempo and key

• Double-click on the stem you dragged into the main project 
area.  This will take you to the Sound tab (or simply select the 
stem/region and click on the Sound tab)

• On the Sound tab, edit the loop tempo and key to match Project 
settings (see right)

4. Line up the "rst beat and syncronize

You’ll need to beat-match each stem or audio "le one at a time .  Trim the beginning (and end of the 
region) so that it starts on the correct beat:

• Start by trimming the beginning of the region/loop in the main 
project area.  Get as close to the downbeat as possible

• Drag loop back so it’s begins at bar 1

• Look at the detailed view in the Sound tab.  Zoom in as far as possible and trim the beginning of 
the loop even further by dragging the Loop Start line to the right

• Press Play (in the main Project area) and listen.  Does the audio "le start on the correct beat?  Is it in 
sync?  Adjust it further if necessary.  Do lots of listening!

5. Crop the loop (audio)

• When you’re satis"ed that it’s playing back in time to the 
metronome, right-click on the loop and choose Set Loop 
To Crop (or press Alt+M)
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6. Rename and Add To Library

• Click on the Sound tab and rename the loop if necessary

• Right-click on the loop and choose Add to Library (the "rst time you do this you might like to set up 
a folder so the loops are organised into a single location)

7. Repeat!

• Drag in the next stem and repeat this process (from step 3) for all other stems

Chopping up long stems into short loops

Once you’ve beat-matched the complete stems, you might like to choose short sections of audio and 
create little snippets or loops for use in your remix.

Creating short loops

• Drag a beat-mapped stem/loop into the project area

• Find the bit you want to keep - usually just a few bars in length

• Place the cursor at the beginning of the section (placing it at the beginning of a bar works best) 
and press Control+T to split the region

• Place the cursor at the end of the section you want to keep (at the end of a bar) and press Control
+T to split the region

• Select the section you want to keep and press Alt+M to Set Loop To Crop (this will mean that the 
little snippet will be cropped and it will “loop” when the end of it it dragged out)

• Click on the Sound tab and rename the loop (see right).  This is 
VERY important!!  Rename it to re#ect the nature of the cropped 
loop - ie. “Guitar ostinato beginning only” or “First line of verse”

• Then, right-click on the loop and choose Add To Library

Sharing Beat-Matched Loops

If you want to share a set of loops that you have beat-matched (or that a student has beat-matched), you 
can drag them all into a project and save all of the Project Files into a folder for others to use in their own 
projects.
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Save the loops into a folder

• First, beat-match the loops

• Put all the loops into a project (don't worry about how it 
sounds - just dump them all in!)

• Save the "le

• Then go to File > Copy Project Files To… > Folder (see 
right)

• Choose an existing folder or click Make New Folder, name the 
folder and click OK

• Mixcraft will save your project to the folder and all of the 
loops used in that project will appear as individual loops inside the folder, alongside the Mixcraft 
"le

How to import the beat-matched loops 

Students can now import the beat-matched loops into their own projects:

• Open Mixcraft and start a new Project 

• Click on the Library tab

• Select +Import (see below)

• Browse for the folder containing the loops

• Choose your desired import settings (particularly the Import location)

• Click Import

• The loops will now appear in the Library, ready for students to use

Exporting a project

When you have "nished your project, you can export it as a WAV or MP3 "le so that it is in a sharable 
format, suitable for burning to CD or adding to a mobile device.

• Go to the File > Mix Down To or click on the Mix Down To Audio button on the toolbar (below)
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• In the Save Your Mix window that opens, name your "le and select an option in the Save As Type 
drop-down (usually MP3 or WAV)

• Click Save
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